Gigya's API returns error "500023 Provider error"
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Issue

Gigya's API returns error "500023 Provider error"

Product

  • Social Login
  • Share

Cause

As stated in Gigya's documentation[1], error code 500023 is returned whenever there is a:

"General error from the provider."

Certain functionalities supported by Gigya, such as Social Login and Sharing, require Gigya's API to interface with the Social Provider's (e.g. Facebook, Twitter, Sina Weibo, QQ, etc..) API to facilitate the login or share process. The error code 500023 is triggered whenever Gigya receives an error while attempting to interface with the Social Provider's API, using both the parameters passed to Gigya's API, as well as the Social Network application credentials configured in the "Providers Configurations"[2] section within the Gigya Admin Console.

Solution

Check against Gigya's documented setup guides for Social Network applications[3] to verify that the application settings are configured as per the information presented in the guides.

If further assistance is required, contact Gigya Support[4] and provide:

  • The Gigya API key
  • A brief description of the issue
  • A test URL and steps to reproduce the issue
  • screenshots of the Social Network application's settings

    Note: In most cases it will not be possible for Gigya Support to effectively assist with troubleshooting issues related to Social Network application configuration, without being able to view the application's settings.

Links

[1]: http://developers.gigya.com/display/GD/Response%20Codes%20and%20Errors%20REST
[2]: https://console.gigya.com/site/partners/Settings.aspx#cmd%3DProviders.Providers
[3]: http://developers.gigya.com/display/GD/Setting%20Up%20External%20Applications%20in%20Social%20Networks
[4]: https://knowledge.gigya.com/GKB_Article?id=a6H400000004DJYEA2

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